请选择 进入手机版 | 继续访问电脑版
查看: 445|回复: 0

Android Studio怎么导入UIKit?

[复制链接]

21

主题

59

帖子

212

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
212
发表于 2018-3-21 11:26:27 | 显示全部楼层 |阅读模式
云信UIKit是开源UI组件,开发者可以基于UIKit快速地实现聊天界面、联系人列表等功能,并实现一些定制化开发。
Android Studio导入UIKit的方法如下:

1、从https://github.com/netease-im/NIM_Android_UIKit点击绿色的 [Clone or download] 按钮,可以选择 [Download ZIP] 下载UIKit的zip包,解压为文件夹。

2、打开Android Studio工程,点击File > New> Import Module,[Source directory] 选择刚才解压的UIKit文件夹,点击 [Finish] 按钮。
[注意] 由于UIKit和开发者当前工程配置的差异,导入后可能遇到以下提示。
*  Cannot getproperty 'compileSdkVersion / buildToolsVersion / minSdkVersion / ...' on extraproperties extension as it does not exist
解决方法:点击Open File,将对应的字段修改为合适的值,或者在Project的build.gradle中添加ext并配置引用,例如(以下版本号仅为示例,请按实际情况配置):
ext {   
        compileSdkVersion =27   
        buildToolsVersion ='27.0.3'   
minSdkVersion =14   
...
}
*  Could not getunknown property 'V7_APPCOMPAT_VERSION / V4_SUPPORT_VERSION /DESIGIN_SUPPORT_VERSION / CONSTRAIT_SUPPORT_VERSION' for object of typeorg.gradle.api.internal.artifacts.dsl.dependencies.DefaultDependencyHandler.
解决方法:点击Open File,将对应的字段修改为下列值,或者在工程的gradle.properties中添加:
V7_APPCOMPAT_VERSIN= 26.+
V4_SUPPORT_VERSION= 26.+
DESIGIN_SUPPORT_VESION= 26.+
CONSTRAIT_SUPPORT_VERSION= 1.0.2

3、最后,在开发者的Module的build.gradle的dependencies中配置对UIKit的依赖,例如:
dependencies {   
     implementation project(path:':uikit')   
     ...
}


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表